指標背離精華合集 源碼 通達信 貼圖 有未來(九轉序列)(圖文)

時間:2019-09-10 12:30:45 作者:admin
后臺-系統-系統設置-擴展變量-(內容頁告位1-手機版)

指標背離精華合集 源碼 通達信 貼圖 有未來(九轉序列)

解放副圖窗口/綜合背離判斷個股走勢
貼圖中的介紹不代表操作建議,
需要自己在對比大量個股走勢之后總結出適合自己的東西
引用的未來函數是九轉序列,不喜勿下!
合集如有問題請各位大神及時指出糾正,謝謝!


DIF:MACD.DIF,COLORLIGRAY;
DEA:MACD.DEA,COLORYELLOW;
強度:IF(DIF>DEA,DIF,DRAWNULL),COLORRED;
強度1:IF(DEA<DIF,DEA,DRAWNULL),COLORMAGENTA;
{}
MACD:(DIF-DEA)*2,COLORSTICK;
MACD2:=MACD;
MJ:=MACD;
S05:=SUM(MJ,0);
QST:=BARSLAST(MJ<0 AND REF(MJ,1)>0)+1;
QXT:=BARSLAST(MJ>0 AND REF(MJ,1)<0)+1;
S5:=IF(MJ>0,S05-REF(S05,BARSLAST(MJ<0)),S05-REF(S05,BARSLAST(MJ>0)))/10;
ST:=IF(MJ>0,REF(QST,QXT)+QXT,REF(QXT,QST)+QST);
RS5:=REF(S5,ST);
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,0,25);
三次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,60)=1;
DRAWICON(三次金叉,0,26);
A002:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背離:=REF(CLOSE,A002+1)>CLOSE AND DIF>REF(DIF,A002+1) AND CROSS(DIF,DEA);

DRAWICON(LONGCROSS(CLOSE,MA(CLOSE,5),17),MACD2,1);
DRAWTEXT(二次金叉>低位金叉,DIF,'金2'),COLORRED;
{RSI買賣點-不需要的可以屏蔽}
C81:=REF(C,1);
RN:=9;
RSI1:=SMA(MAX(C-C81,0),RN,1)/SMA(ABS(C-C81),RN,1)*100;
低點:=CROSS(RSI1,20);
STICKLINE(低點,0.1,0,0.3,0),COLORYELLOW;
DRAWICON(低點, 0.15,1);
DRAWTEXT(低點, 0.14,'←底'),COLORYELLOW;
頂:=CROSS(80,RSI1);
DRAWICON(頂, DIF*1.15,2);
DRAWTEXT(頂, DIF*1.1,'←減/清倉'),COLORGREEN;

{定量結構}


{底部結構預警}
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}
N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒數第二次死叉與倒數第一次死叉的區間}
N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒數第三次死叉與倒數第二次死叉的區間}
CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盤價}
DIFL1:=LLV(DIF,N1+1),NODRAW;

CL2:=REF(CL1,N1+1),NODRAW;{倒數第二次死叉與倒數第一次死叉之間的最低收盤價}
DIFL2:=REF(DIFL1,N1+1),NODRAW;
CL3:=REF(CL2,N1+1),NODRAW;{倒數第三次死叉與倒數第二次死叉之間的最低收盤價}
DIFL3:=REF(DIFL2,N1+1),NODRAW;
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背離:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背離:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B6:直接底背離 OR 隔峰底背離,NODRAW;
BG:((MDIFB2>REF(MDIFB2,1))*REF(直接底背離,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背離,1)),NODRAW;
底背離消失:=(REF(直接底背離,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背離,1) AND DIFL1<=DIFL3);
DRAWTEXT(TFILTER(B6,MACD>0,1),(DIF+MACD),'鈍化'),COLORRED;
STICKLINE(B6 OR BG,DIF,DEA,1,-1),COLORRED;
DRAWTEXT(TFILTER(底背離消失,B6,1),(DIF+MACD),'消失'),COLORYELLOW;
DRAWTEXT(TFILTER(BG,MACD>0,1),DIF*1.1,'M底背'),COLORMAGENTA;


{頂部結構預警}

金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}
M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒數第二次金叉與倒數第一次金叉的區間}
M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒數第三次金叉與倒數第二次金叉的區間}
CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盤價}
DIFH1:=HHV(DIF,M1+1),NODRAW;

CH2:=REF(CH1,M1+1),NODRAW;{倒數第二次金叉與倒數第一次金叉之間的最高收盤價}
DIFH2:=REF(DIFH1,M1+1),NODRAW;
CH3:=REF(CH2,M1+1),NODRAW;{倒數第三次金叉與倒數第二次金叉之間的最高收盤價}
DIFH3:=REF(DIFH2,M1+1),NODRAW;
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接頂背離:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰頂背離:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T6:直接頂背離 OR 隔峰頂背離,NODRAW;
TG:((MDIFT2<REF(MDIFT2,1))*REF(直接頂背離,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰頂背離,1)),NODRAW;
頂背離消失:=(REF(直接頂背離,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰頂背離,1) AND DIFH1>=DIFH3);
DRAWTEXT(TFILTER(T6,MACD<0,1),(DIF+MACD),'鈍化'),COLORGREEN;
DRAWTEXT(TFILTER(頂背離消失,T6,1),(DIF+MACD),'消失'),COLORYELLOW;
STICKLINE(T6 OR TG,DIF,DEA,1,-1),COLORLIGREEN;
DRAWTEXT(TFILTER(TG,MACD<0,1),DIF*1.02,'M頂背'),COLORMAGENTA;
{}


{9轉};

A001:=C>REF(C,4);
NT:=BARSLASTCOUNT(A001);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9)OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;
DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;
B001:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B001);
TJ21:=NT0=9;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,MACD*0.98,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,MACD*0.98,'9'),COLORRED;
{};

TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TRR;
MDI:= MDM*100/TRR;
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1"
AND CROSS("RSI.RSI2","RSI.RSI1");


DRAWTEXT(B2>0,DIF*1.2,'K底'),COLORFF00FF;
DRAWTEXT(D2>0,DIF*1.2,'K頂'),COLORFFCC66;
DRAWTEXT(B3>0,DIF*1,'R底'),COLORYELLOW;
DRAWTEXT(D3>0,DIF*1,'R頂'),COLORFFFFFF;


{臥底藏龍}{副圖}{選股}
TDJ1:=(H-L)/REF(C,1)>0.05;
YUL1:=COUNT(TDJ1,5)>1;
TU1:=CLOSE/MA(C,40)<0.74;
啟動1:=TDJ1 AND YUL1 AND TU1;
ZC:=REF(CLOSE,1);
VAR1:=SMA(MAX(CLOSE-ZC,0),7,1)/SMA(ABS(CLOSE-ZC),7,1)*100;
VAR2:=((MA(C,30)-LOW)/MA(C,60))*200;
GL1:=FILTER(REF(VAR1,1)<20 AND VAR1>REF(VAR1,1),5);
波段1:=FILTER(GL1 AND REF(啟動1,1) AND VAR2>20 AND C>REF(C,1),10);
MA5:=EMA(C,5);{好股票WWW.GOODGUPIAO.COM}
EM5:=EMA(MA5,5);
VAR3:=ABS(MA5-EM5);
VAR4:=MA5-REF(MA5,1);
VAR5:=VAR4-REF(VAR4,1);
VAR6:=(VAR4+VAR5)/2;
TDF1:=POW(VAR3,1)*POW(VAR6,3);
NTDF1:=TDF1/HHV(ABS(TDF1),15);
確定1:=波段1 AND CROSS(NTDF1,-0.05);
選股1:=FILTER(REF(啟動1,1) AND (確定1 OR C>REF(C,1)) AND "MACD.MACD"(12,26,9)>-1.5,10);
臥底1:(COUNT(選股1,13)>=1 AND (波段1 OR 確定1))*0.4,COLORRED;
DRAWTEXT(臥底1=0.4,0.3,'←臥底'),COLORRED;


{};
A882:=(C - REF(C,1)) / REF(C,1) * 100;
A883:=COUNT(A882 > 8,120);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.2,0,0,A883),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'【關注級別大的股票】 '),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.13,0,0,'級: '),COLORYELLOW;




指標背離精華合集 源碼 通達信 貼圖 有未來(九轉序列)

指標背離精華合集 源碼 通達信 貼圖 有未來(九轉序列)

指標背離精華合集 源碼 通達信 貼圖 有未來(九轉序列)

指標背離精華合集 源碼 通達信 貼圖 有未來(九轉序列)


后臺-系統-系統設置-擴展變量-(內容頁告位2-手機版)
聲明:本文內容由互聯網用戶自發貢獻自行上傳,本網站不擁有所有權,未作人工編輯處理,也不承擔相關法律責任。如果您發現有涉嫌版權的內容,歡迎發送郵件至本站聯系郵箱進行舉報,并提供相關證據,工作人員會在5個工作日內聯系你,一經查實,本站將立刻刪除涉嫌侵權內容。
后臺-系統-系統設置-擴展變量-(內容頁告位3-手機版)
官方彩票app